paralution + openfoam. What version to use?

Front page Forums Installation paralution + openfoam. What version to use?

This topic contains 4 replies, has 2 voices, and was last updated by  ntr 3 years, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #749

    joegi
    Participant

    Hi,
    I wonder if there is a specific openfoam version to be used with paralution.

    I trying to use paralution with openfoam 2.3.x but it doesn’t wokt.

    Checking the forum it seems that paralution is compatible only with OF 2.1.1

    Regards,

    Joel

    #750

    joegi
    Participant

    Hi,

    Ok I am trying to compile OF2.1.1 with paralution. But I am getting this error:

    Making dependency list for source file Laplace.C
    make: *** No rule to make target `lnInclude/lduMatrix.H’, needed by `/home/joegi/OpenFOAM/paralution/paralution-0.6.1/src/plug-ins/OpenFOAM/matrices/lduMatrix/solvers/paralution_PCG/paralution_PCG.dep’. Stop.

    Any clues?

    Btw, the paralution library compiled fine.

    j

    #751

    ntr
    Participant

    Hi Joegi,
    did you source the OpenFOAM environment?

    Best regards
    ntr

    #752

    joegi
    Participant

    Yes, sourced and recompiled.

    Just to make it clear, paralution runs in OF2.1.1?. I am trying to compile the Laplace case.

    regards,

    j

    #753

    ntr
    Participant

    Hey Joegi,
    yes, PARALUTION runs with OF 2.1.x. Can you delete the file /home/joegi/OpenFOAM/paralution/paralution-0.6.1/src/plug-ins/OpenFOAM/matrices/lduMatrix/solvers/paralution_PCG/paralution_PCG.dep and try again?

    Best regards,
    ntr

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.